Service Degradation - Flow Production Tracking
Incident Report for Flow Production Tracking
Postmortem

Between 17:00 PDT on May 1, 2024 and 03:10 PDT on May 2, 2024, Flow Production Tracking Desktop users experienced a service degradation.

Impacted Services

Local integrations failed to load during the incident window, affecting various DCC and publishing workflows that rely on FPTR Desktop.

Root Cause

An SSL certificate used by the FPTR Desktop app had been renewed but was not fully deployed prior to the expiry of the existing certificate. This lead to an expired certificate being offered to FPTR Desktop during the incident.

The incident was resolved by deploying the renewed certificate.

Autodesk Actions

Autodesk has completed a post-incident analysis of the event and identified actions to be taken. These include the following:

  • Additional monitoring of FPTR Desktop certificate expiry

  • Improved process for FPTR Desktop certificate renewal

Thank you for your patience and understanding.

Posted May 09, 2024 - 16:26 UTC

Resolved
This incident has been resolved.
Posted May 02, 2024 - 10:28 UTC
Monitoring
A fix has been implemented. You may need to restart Flow PTR Desktop before retrying desktop integrations.
Posted May 02, 2024 - 10:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 02, 2024 - 08:55 UTC
Investigating
Requests made by desktop integrations may unexpectedly fail. This issue is under investigation.
Posted May 02, 2024 - 08:33 UTC
This incident affected: Flow Production Tracking and Notification Service.